Happy Business Starts Here

With Bundling enabled, Products are not synced to Zuora and there are no failures, success shown

Highlighted
Zuora Support

With Bundling enabled, Products are not synced to Zuora and there are no failures, success shown

With Bundling enabled, when trying to sync Product from salesforce to Zuora by clicking "Sync to Zuora" at the Product level ,it is not synced

 

On checking the sync details, there are no success, failure reasons are shown and is blank






If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

1 REPLY 1
Zuora Support

Re: With Bundling enabled, Products are not synced to Zuora and there are no failures, success shown

Multi Entity is enabled in the Salesforce org

 

On reviewing the debu logs, it has been identified that error is thrown from below stack trace

 

13:50:35.0 (286301818)|FATAL_ERROR|System.AssertException: Assertion Failed

13:50:35.0 (276537623)|USER_DEBUG|[1060]|DEBUG|Separate 1 wrappers by type.
13:50:35.0 (277674429)|USER_DEBUG|[1082]|DEBUG|request.objectName:[Product2], request.isDeleted:[false], request.zuoraId:[null]
13:50:35.0 (285933537)|EXCEPTION_THROWN|[147]|System.AssertException: Assertion Failed
13:50:35.0 (286171333)|SYSTEM_MODE_EXIT|false
13:50:35.0 (286301818)|FATAL_ERROR|System.AssertException: Assertion Failed

Class.zqu.ZProductManager.getZApiInstance: line 147, column 1

 

From the managed package code, below is the code line from where error is thrown

if (ZQUtil.isMultiEntityEnabled) System.assert(entityId != null);

On the product records,there is no Billing entity field populated and is blank

 

The issue was resolved once the Billing entity field is selected( this populates the entity id field) and the Product is now synced to Zuora






If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √