Happy Business Starts Here

Zuora Support

Unable to enable Orders manually on salesforce.

Problem:

 

After having Orders setting enabled by zuora support on tenant, trying to enable the same on salesforce org by below mentioned steps provided on KC

To enable the setting manually on salesforce
Please follow this:
https://knowledgecenter.zuora.com/CA_Commerce/C_Zuora_Quotes/Orders_in_Zuora_Quotes/Enable_and_Confi...

If you want to immediately update the Enable Orders setting before the next schedule permission check happens, run the following to force a permission check:

  • In Salesforce, open Developer Console.
  • Navigate to Debug > Open Execute Anonymous Window.
  • In the Enter Apex Code window, type: 
  •  zqu.RefreshCustomSettingSchedulable.refreshOrdersPermission();
  •  Click Execute.

 

but orders setting is still not enabled on advanced quote configuration settings. 

 

 






If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

1 REPLY 1
Highlighted
Zuora Support

Re: Unable to enable Orders manually on salesforce.

Solution

 

If you want to immediately update the Enable Orders setting before the next schedule permission check happens, run the following to force a permission check:

In Salesforce, open Developer Console.
Navigate to Debug > Open Execute Anonymous Window.
In the Enter Apex Code window, type: 
zqu.RefreshCustomSettingSchedulable.refreshOrdersPermission();
Click Execute.
Verify that the Enable Orders setting is correctly updated in Advanced Quoting Configuration Settings in the Zuora Config tab.
Your Salesforce org and your Zuora tenant must both be pointing to each other. The refreshOrdersPermission operation will fail, scheduled or manual, if the Salesforce Credentials configured in your Zuora tenant do not point to the Salesforce org you are using.

After running the above, if you notice that Orders is still not enabled on your salesforce org (Under Zuora config--Advanced Configuration setting), please check Apex job.
If you notice error like

Firrst error: Unexpected character ('<' (code 60)): expected a valid value (number, String, array, object, 'true', 'false' or 'null') at input location [1,2]

Please perform the steps below:

  • Please run the following query
select Id,Name from zqu__Billingentity__c
  • It the above query returns >0 record, run the following
delete [select Id,Name from zqu__Billingentity__c limit 10000];
  • Then run the following again
  • In Salesforce, open Developer Console.
  • Navigate to Debug > Open Execute Anonymous Window.
  • In the Enter Apex Code window, type: 
    zqu.RefreshCustomSettingSchedulable.refreshOrdersPermission();
  • Click Execute.





If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √