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Salesforce Quote can't be sent to Zuora
Problem:
Sending a Quote from Salesforce to Zuora is not working in our lightning enviornment.
Solution needed asap.
Root cause:
Customer created some new picklist values in the "zqu__Status__c" field (Quote object) and used in their approval process which is not advisable from Zuora managed package side. Because "Send to Zuora" functionality button works on the basis of the "NEW" picklist value of the zqu__Status__c field. Only if the Status field is "New", quote can be sent to Zuora.
Solution:
- If customer like to use the standard approval process in the Quoting flow, they can use the "zqu__ApprovalStatus__c" field in the quote object which is introduced in version 7.1.1 of Zuora Quotes - https://knowledgecenter.zuora.com/Zuora_Release_Notes/Zuora_CPQ_Release_Notes/ZZ_Previous_Zuora_CPQ_...
- Also there is another configuration called "Approval Quote Status" in the "Quote Configuration Settings" settings. If they enable this option, only the approved quotes(zqu__ApprovalStatus__c) can be sent to Zuora. Whatever value is set in this configuration, send to Zuora works based on that.
https://knowledgecenter.zuora.com/CPQ/C_Zuora_Quotes/CB_Zuora_Quotes_Configuration_Settings/B_Quote_...
- If the "zqu__ApprovalStatus__c" field doesn't match the value in the "Approval Quote Status" option in the Quote configuration settings, we cannot send the quote to Zuora. The submit button will be disabled and the below message will be shown.
Once the customer used "zqu__ApprovalStatus__c" field, they are now able to use Approval process as per their business case.
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