Happy Business Starts Here

Re: InvalidBatch : Attached file is too large: request.txt. Maximum bytes per file is 10485760

Highlighted
Zuora Support

InvalidBatch : Attached file is too large: request.txt. Maximum bytes per file is 10485760

My Zuora 360 Sync is failing with the following error in Zuora's sync log.

 

Error: 
There has been an unknown internal error happened. (InvalidBatch : Records not processed)
StackTrace:
[AsyncApiException  exceptionCode='InvalidBatch'
 exceptionMessage='Records not processed'
]

 at com.sforce.async.BulkConnection.parseAndThrowException(BulkConnection.java:108)
 at ...2 more
 at com.zuora.sync.sfdc.migration.impl.SfdcMigrationAgentImpl$SfdcBulkApiConnection$8.operation(SfdcMigrationAgentImpl.java:1200)
 at com.zuora.sync.sfdc.migration.impl.SfdcMigrationAgentImpl$SfdcBulkApiCon

 

When reviewing the Bulk Data Load Jobs log in Salesforce, I found the following error.

 

InvalidBatch : Attached file is too large: request.txt. Maximum bytes per file is 10485760.

How can I resolve this error?



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Zuora Support

Re: InvalidBatch : Attached file is too large: request.txt. Maximum bytes per file is 10485760

Turbo Sync & Scheduled Sync uses Bulk Data Load Jobs to sync data from Zuora to Salesforce.  By default, each batch job has 9,000 records.  The error indicates that the batch file size is too large which is beyond Salesforce's limitation of 10,485,760 bytes (~ 10 MBs).

 

To resolve the issue, there are two options.

 

  1. Reach out to Salesforce Support to see if the file size for your org can be increased
  2. In Zuora reduce the number of records per batch by selecting a smaller value for Sync Batch Size setting

setting.png

 

Please note that with option (2) the smaller the size is, the longer your sync will take.



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

View solution in original post

1 REPLY 1
Highlighted
Zuora Support

Re: InvalidBatch : Attached file is too large: request.txt. Maximum bytes per file is 10485760

Turbo Sync & Scheduled Sync uses Bulk Data Load Jobs to sync data from Zuora to Salesforce.  By default, each batch job has 9,000 records.  The error indicates that the batch file size is too large which is beyond Salesforce's limitation of 10,485,760 bytes (~ 10 MBs).

 

To resolve the issue, there are two options.

 

  1. Reach out to Salesforce Support to see if the file size for your org can be increased
  2. In Zuora reduce the number of records per batch by selecting a smaller value for Sync Batch Size setting

setting.png

 

Please note that with option (2) the smaller the size is, the longer your sync will take.



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

View solution in original post