Happy Business Starts Here

Zuora Staff

Tax schedule error encountered in Z-Suite Sync

Question or Problem Statement:

We have enable Taxation on our Zuora Products but when we ran our Z-Suite sync to Netsuite, we received the following tax errors:

Code: USER_ERROR 
Type: ERROR 
Message: Please enter value(s) for: Tax Schedule

How do we solve this error? 

 



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

1 REPLY 1
Highlighted
Zuora Staff

Re: Tax schedule error encountered in Z-Suite Sync

Solution:

The NetSuite Default Tax Schedule is required in the Sync Preference if the "Advanced Taxes" feature is enabled in your NetSuite environment.

As a background information, for NetSuite clients with the Advanced Taxes feature enabled, you must configure a Default NetSuite Tax Schedule in the Integration Setup to use when syncing Product Rate Plan Charges.

You would have to "Create this Tax Schedule" (if it still does not exist) and configure it in NetSuite to not calculate taxes if tax is calculated by Zuora.

You can view the status of the Advanced Taxes feature in NetSuite by selecting Setup -> Company -> Enable Features, selecting the Accounting tab, then viewing Advanced Taxes in the Advanced Features section.

Here are the steps the add the "Tax Schedule" in your Sync Preferences:

  1. Via Zuora's web UI, click "settings" (upper right);
  2. click "Z-Billing Settings";
  3. click "Manage NetSuite Integration";
  4. scroll down and click "edit"; 5.click "Sync Preferences";
  5. enter the name of the default Tax Schedule on the field "NetSuite Default Tax Schedule".


If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √