Happy Business Starts Here

Re: UTF-8 encoding related error


When importing a CSV file to Zuora, be careful with character codes

I and my customers are Japanese. We may use Japanese as Units of Measure (UOM).

For example, we use "回" which means "times".


By the way, I know that the world standard character code is UTF.
Meanwhile, in Japan, it is still often to use something specific to our country as the character code of the text file (Shift JIS, etc.).

The default setting of the text editor is often Shift JIS.


Well, I encountered an error trying to import the CSV file of Usage that written Japanese UOM into Zuora.
Yes, the problem was in the character code.

The UOM "回" set on Tenant UI was recognized by Zuora as UTF-8,

and Zuora did not regard the same "回" of the character code Shift JIS I wrote in the CSV file.

I received the following error message about UOM (So-called "Mojibake"):

"",The UOM does not match,A00098284,��,1,2017/10/1,2017/10/1,A-S00280829,C-00280841,

I set the character code to UTF-8 in my text editor setting and avoided this error.


I call attention to people who are not in English speaking countries.
When importing a CSV file to Zuora, be careful with character codes.


UTF-8 encoding related error



I have an issue related to this same UTF-8 encoding and was wondering if anyone here could help me with a hint or something.

We had a new customer with a special address, containing special characters("Bács") registering to our backend and Zuora throwed an exception 

"Detail":[],"Reason":{"Text":"com.ctc.wstx.exc.WstxIOException: Invalid UTF-8 middle byte 0x63 (at char #1047, byte #127)"},"Code":{"Value":"soapenv:Receiver"}} at the time when the contact was trying to be created. I've tried encoding in UTF-8 the whole request we make and still I got the same error. Same request to https://rest.apisandbox.zuora.com/v1/action/create from Postman works.

I appreciate your help,





Re: UTF-8 encoding related error

Solved it in the meantime.

We use Camel in our backend API and although we sent request in the JSON format, I had to explicitly specify to use the UTF-8 format in the main Camel route to Zuora:


This fixed our bug.