Happy Business Starts Here

Re: Significant Increase in PayPal 14017 Errors

Highlighted
Valued Scholar

Significant Increase in PayPal 14017 Errors

Since the start of June we have had a 50% increase in the number of our paypal BAID payments failing to process for "10417-Instruct the customer to retry the transaction using an alternative payment method from the customers PayPal wallet. The transaction did not complete with the customers selected payment method.".

 

I've looked a few different cohorts and there doesn't seem to any particular group of our customers (new or existing) that are coming up against this more frequently than another.

 

PayPal's documentation indicates this can be caused by the card associated with the BAID being declined by the issuing bank or the result of being blocked by Paypal's own fraud filtering. Unfortunately PayPal provides no insight into which one it is. 

 

I have no idea if this is related to something we changed or something PayPal changed or maybe even something in how Zuora feeds data to PayPal for these payments (I am in the accounting department so I am approaching this from a non-technical background).

 

Has anyone else come up against this or noticed a similar trend recently?

4 REPLIES 4
Highlighted
Zuora Alumni

Re: Significant Increase in PayPal 14017 Errors

Hi @rlaker

 

These errors are being generated by your gateway.  Your best course of action would be to contact your account manager at Paypal regarding these errors.    If needed, we can provide to them log files of these transaction.

 

Robert



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

Highlighted
Valued Scholar

Re: Significant Increase in PayPal 14017 Errors

Hi Robert,

 

What version of PayPal's API does Zuora use for submitting payments to PayPal? We are currently using v94 for setting up the initial BAID, as far as I can tell the current version from PayPal is v204. Has Zuora recently changed versions for the PayPal API?

 

Thanks,

Highlighted
Zuora Alumni

Re: Significant Increase in PayPal 14017 Errors

Hi @rlaker

 

The api version we are using is 119.   I've check an account that is using PaypalEC several months past and we did not see any changes in the api version.   I would like to take a look at your account and verify your transactions for the version # just in case.   Can you create a ticket and put ATTENTION to Robert in the subject line?   Thanks.

 

Robert



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

Highlighted
Newly Enrolled

Re: Significant Increase in PayPal 14017 Errors

I know it's been a long time ago but I met the same issue recently. 

Just wondering how you guys fix it.

Thanks!