Happy Business Starts Here

Highlighted
Zuora Support
Zuora Support

“Null” was returned in ”AmountHomeCurrency“ from Zuora UI, SOAP API, and AQuA API

Problem:

“Null” was returned in ”AmountHomeCurrency“ or other currency conversion fields, such as below, from AOQL export, AQUA or DSE report.

  • Invoice.AmountHomeCurrency
  • Invoice.AmountCurrencyRounding
  • Invoice.AmountWithoutTaxHomeCurrency
  • Invoice.AmountWithoutTaxCurrencyRounding
  • Invoice.ExchangeRate
  • invoice.ExchangeRateDate
  • Invoice.ProviderExchangeRateDate

Cause:

There is no available exchange rate uploaded when exporting the data.
After enabling currency conversion feature, you can export transaction amounts converted into your home currency and other specified currencies using the Zuora UI, SOAP API, and AQuA API.
However, if custom foreign exchanges rate is used in Zuora, and the corresponding foreign exchange rate hasn't been uploaded, null will be returned.
For details about how to upload foreign exchange rate, please refer to https://knowledgecenter.zuora.com/CC_Finance/Mass_Updater/Import_Foreign_Exchange_Rates
For details about "AmountHomeCurrency" field, please refer to below documentation.
 

Solution:

Please check Mass Updater history, or use Get Custom Foreign Currency Exchange Rates REST API to query and double-check if the exchanges rate against "ProviderExchangeRateDate" was not uploaded.

  • If yes, then please upload the missing foreign exchange rate and run the export again.
  • If no, please compare the uploading and export time. Please upload the exchange rate first, then export.

 

 



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √