Happy Business Starts Here

Zuora SOAP API sandbox login failure

Highlighted
Tutor

Zuora SOAP API sandbox login failure

Hi,

 

I am trying to use the SOAP API to login to the zuora sandbox. I currently have an API user set up in the sandbox and following are the details of the request I'm making:

 

Endpoint - https://apisandbox.zuora.com/apps/services/a/79.0

Request Type - POST

Request Body:

<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns2="http://object.api.zuora.com/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:ns1="http://api.zuora.com/">
    <SOAP-ENV:Body>
        <ns1:login>
            <ns1:username>myusername</ns1:username>
            <ns1:password>mypassword</ns1:password>
        </ns1:login>
    </SOAP-ENV:Body>
</SOAP-ENV:Envelope>

 

Following is the response I'm getting:

 

<html>
    <body>
        <h2>405 not supported</h2>
    </body>
</html>

I'm doing everything as mentioned here. Any help is appreciated.

 

Thanks,

Avi

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Support SME

Re: Zuora SOAP API sandbox login failure

Hi @avi91 you've mentioned you're using POST, and 405 is a not supported (HTTP) message, so I assume you were using the default Content-Type header, and not text/xml.

 

My login() call has the following RAW data:

 

 

POST https://apisandbox.zuora.com/apps/services/a/85.0 HTTP/1.1
Accept-Encoding: gzip,deflate
Content-Type: text/xml;charset=UTF-8
SOAPAction: ""
Content-Length: 465
Host: apisandbox.zuora.com
Connection: Keep-Alive
User-Agent: Apache-HttpClient/4.1.1 (java 1.5)

Response:

HTTP/1.1 200 OK
Content-Security-Policy-Report-Only: xxx
Server: Zuora App
Content-Type: text/xml;charset=UTF-8
Content-Length: 731
Expires: Fri, 23 Feb 2018 19:13:55 GMT
Cache-Control: max-age=0, no-cache, no-store
Pragma: no-cache
Date: Fri, 23 Feb 2018 19:13:55 GMT
Connection: keep-alive

 

 

Let me know if this helps!



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

View solution in original post

3 REPLIES 3
Highlighted
Support SME

Re: Zuora SOAP API sandbox login failure

Hi @avi91 you've mentioned you're using POST, and 405 is a not supported (HTTP) message, so I assume you were using the default Content-Type header, and not text/xml.

 

My login() call has the following RAW data:

 

 

POST https://apisandbox.zuora.com/apps/services/a/85.0 HTTP/1.1
Accept-Encoding: gzip,deflate
Content-Type: text/xml;charset=UTF-8
SOAPAction: ""
Content-Length: 465
Host: apisandbox.zuora.com
Connection: Keep-Alive
User-Agent: Apache-HttpClient/4.1.1 (java 1.5)

Response:

HTTP/1.1 200 OK
Content-Security-Policy-Report-Only: xxx
Server: Zuora App
Content-Type: text/xml;charset=UTF-8
Content-Length: 731
Expires: Fri, 23 Feb 2018 19:13:55 GMT
Cache-Control: max-age=0, no-cache, no-store
Pragma: no-cache
Date: Fri, 23 Feb 2018 19:13:55 GMT
Connection: keep-alive

 

 

Let me know if this helps!



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

View solution in original post

Highlighted
Tutor

Re: Zuora SOAP API sandbox login failure

Thanks @Viktor, that solved the problem. I'm able to login successfully now.

Highlighted
Support SME

Re: Zuora SOAP API sandbox login failure

Glad to hear @avi91 , happy to help!



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √