Happy Business Starts Here

zLogin() Error: Invalid login. User name and password do not match

Highlighted
Zuora Support

zLogin() Error: Invalid login. User name and password do not match

Problem – If you are running zapi.zLogin() call and its returning "Invalid login. User name and password do not match."  As shown below

zLoginCallError.png






If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Zuora Support

Re: zLogin() Error: Invalid login. User name and password do not match

Solution – Following are the steps to check when you are receiving this error

  1. Go to your Salesforce Org and then navigate to Connection Setup tab. Make sure that the Endpoint, Username & Password added there are right and when you hit “Test Connection” button it shows “Connected to Zuora Successfully”. If the connection fails, please enter the correct credentials. 

    Please find below article for reference.
    360 Connection Settings

  2. From execute anonymous window, when you call zLogin() method, plz try explicitly setting the EndPoint and also explicitly pass the username, password in the zLogin call (as documented in the article below) and see if that works. If this also does not work, please check your credentials again and make sure you follow the step 1. 

    Please find below article for reference.
    zLogin() Method

  3. As mentioned in the above article for 360 connection settings-
    The Test Connection button only tests whether the username / password are valid.  It does not check whether the password has expired. Thus it is possible that you may see a success message in this test, but still get an error when actually connecting to Zuora if the user account has expired.

    Try resetting the password of the API user added and see if that helps. Please note that we recommend your API user to open the password link in Incognito Window. Otherwise, you may experience cookie issues and may not be able to log-in with another user easily. 

    Please find below article for reference.
    Create an API User





If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

View solution in original post

Highlighted
Zuora Support

Re: zLogin() Error: Invalid login. User name and password do not match

If none of the above helps one last very rare reason -  check the set up 360 Connection Setup at the profile level, user level as well as the Organizational level. Follow the steps below. 

Issue: The Profile and User level settings of the Connection Setup of the 360 Sync in Salesforce is set up with invalid credentials.

 

Fix: Delete all Profile and User level settings of the Connection Setup of the 360 Zuora sync app in Salesforce. This can be done by taking the following steps:

  1. Navigate to the Zuora 360 Sync app from the dropdown in the top right and click the Connection Setup tab as shown below. 

    Picture1.png

  2. In the Location Settings section, change the drop down from Organization to "Profile", and set the Profile to "API User"

    Picture1.png

  3. Click the Delete button as shown below. 

    Picture1.png


  4. Follow the same steps, delete the setting for the following combination of Location Settings attributes
    1. Profile - System Administrator
    2. Your user. 

 






If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

View solution in original post

2 REPLIES 2
Highlighted
Zuora Support

Re: zLogin() Error: Invalid login. User name and password do not match

Solution – Following are the steps to check when you are receiving this error

  1. Go to your Salesforce Org and then navigate to Connection Setup tab. Make sure that the Endpoint, Username & Password added there are right and when you hit “Test Connection” button it shows “Connected to Zuora Successfully”. If the connection fails, please enter the correct credentials. 

    Please find below article for reference.
    360 Connection Settings

  2. From execute anonymous window, when you call zLogin() method, plz try explicitly setting the EndPoint and also explicitly pass the username, password in the zLogin call (as documented in the article below) and see if that works. If this also does not work, please check your credentials again and make sure you follow the step 1. 

    Please find below article for reference.
    zLogin() Method

  3. As mentioned in the above article for 360 connection settings-
    The Test Connection button only tests whether the username / password are valid.  It does not check whether the password has expired. Thus it is possible that you may see a success message in this test, but still get an error when actually connecting to Zuora if the user account has expired.

    Try resetting the password of the API user added and see if that helps. Please note that we recommend your API user to open the password link in Incognito Window. Otherwise, you may experience cookie issues and may not be able to log-in with another user easily. 

    Please find below article for reference.
    Create an API User





If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

View solution in original post

Highlighted
Zuora Support

Re: zLogin() Error: Invalid login. User name and password do not match

If none of the above helps one last very rare reason -  check the set up 360 Connection Setup at the profile level, user level as well as the Organizational level. Follow the steps below. 

Issue: The Profile and User level settings of the Connection Setup of the 360 Sync in Salesforce is set up with invalid credentials.

 

Fix: Delete all Profile and User level settings of the Connection Setup of the 360 Zuora sync app in Salesforce. This can be done by taking the following steps:

  1. Navigate to the Zuora 360 Sync app from the dropdown in the top right and click the Connection Setup tab as shown below. 

    Picture1.png

  2. In the Location Settings section, change the drop down from Organization to "Profile", and set the Profile to "API User"

    Picture1.png

  3. Click the Delete button as shown below. 

    Picture1.png


  4. Follow the same steps, delete the setting for the following combination of Location Settings attributes
    1. Profile - System Administrator
    2. Your user. 

 






If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

View solution in original post