Happy Business Starts Here

Valued Scholar

Zuora Quotes and Zuora 360 upgrade version compatibility

We are currently running Zuora 360 2.70.3 and Zuora Quotes 5.100.7. Is our older version of Zuora Quotes compatible with Zuora 360 4.11? Or do we have to upgrade both at the same time?

 

Our customizations to Zuora Quotes makes it difficult to upgrade, and we're hoping to upgrade Zuora 360 first.

3 REPLIES 3
Guru

Re: Zuora Quotes and Zuora 360 upgrade version compatibility

I know that certain versions of Quotes/CPQ require a minimum version of 360 to operate properly. I believe that you should be able to use a newer version of Quotes and CPQ due to the way the Salesforce platform handles version dependencies (i.e. older code can still be referenced even if the package is updated)

 

I would highly suggest opening a case to have support confirm this and would definitely test this in a sandbox environment first. @eric-neto or @nathanc may be able to give some insights.

 

On a side note, I will say that moving up the latest version of Quotes is worth the effort if you can do so, the newer product selector and rules engine are pretty slick :-)

 

-Jacob

Guru

Re: Zuora Quotes and Zuora 360 upgrade version compatibility

You will also need to do incremental updates as you can't do a leap from where you are to latest. I agree to have support guide you through which steps to take.

We also have a lot of custom code for Z Quotes.

 

The removal of the QuoteCharge object was a huge hurdle for us in moving up.  It required a lot of testing in sandboxes to get the migration of the quote data to work.  I remember doing manual 'massaging' of data for this to work. I have had to made code changes for several of the releases to work with my custom code.

 

I would be wary of not keeping the versions of 360 and z-quotes on a similar path.

Maggie Longshore
Zuora Alumni

Re: Zuora Quotes and Zuora 360 upgrade version compatibility

I will say the packages were created from the start to be independent.  This is why they have different namespaces and why we don't have anything officially published that requires you to have one version or another.

 

Having said that, there are certain setting in Quotes such as Get Billing Accounts from 360 or Get Subscriptions from 360 that create a dependency on 360, but these are configurable.  Quotes can be run entirely independently of 360.