Happy Business Starts Here

Zuora Connection Settings errors out and shows "Invalid login. User name and password do not match."

Highlighted
Zuora Support

Zuora Connection Settings errors out and shows "Invalid login. User name and password do not match."

Problem - If you have created a new API User and trying to enter the credentials in "Zuora Connection Settings" but you see the error below when trying to test the connection -

 

Server Exception: <?xml version='1.0' encoding='UTF-8'?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Body><soapenv:Fault xmlns:fns="http://fault.api.zuora.com/"><faultcode>fns:INVALID_VALUE</faultcode><faultstring>Invalid login. User name and password do not match.</faultstring><detail><fns:LoginFault><fns:FaultCode>INVALID_VALUE</fns:FaultCode><fns:FaultMessage>Invalid login. User name and password do not match.</fns:FaultMessage></fns:LoginFault></detail></soapenv:Fault></soapenv:Body></soapenv:Envelope>






If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

1 REPLY 1
Zuora Support

Re: Zuora Connection Settings errors out and shows "Invalid login. User name and password do no

Solution - In this specific case, customer was getting an error as mentioned above even when they created the new API User and was sure that username password were correct. Here are the steps we performed to resolve this issue -

  • We created a new API User (You can use the same API User credentials you have) in Zuora.
  • Added the new user credentials in Zuora Config --> Zuora Connection Settings
  • Test Connection which was failing with the error "Invalid login. User name and password do not match."
  • Hit Save this time instead of testing the connection.
  • Click on "Edit Settings".
  • Hit "Test connection" now which worked without any issues.





If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √