Happy Business Starts Here

When sending Quote to Zuora, Electronic Payment Method is not updating Auto Pay, default payment

Zuora Support

When sending Quote to Zuora, Electronic Payment Method is not updating Auto Pay, default payment

Problem - In this specific case, customer had the Electronic Payment Method Setting in the Zuora Config (in Salesforce) set to "Set default, auto-pay" as shown below.

ElecPaymentProcOptions.png

 

Still when they were sending the quote to Zuora with electronic payment ID set on the Quote, the payment method was being added to the customer's account in Zuora under "Electronic Payment Method" but not set as default & auto-pay. 




If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

1 REPLY 1
Zuora Support

Re: When sending Quote to Zuora, Electronic Payment Method is not updating Auto Pay, default payment

If you have followed both of these documents mentioned below but still facing this issue, please see solution. 

Process Payment in Zuora Billing

Quote Configuration Settings

 

Solution - In this specific case, customer was using Salesforce/Zuora/Sertifi integration. They were using Sertifi to capture the credit card information. When they were submitting the Quote to Zuora, the credit card was added to the Billing Account, however, it was not selected as the default payment method and the Auto-Pay box wasn't checked.

 

After investigation we figured out that this was happening since they had the "Generate Invoice" and "Process Payment" checkboxes unchecked. When we checked these boxes as shown below everything worked as expected. 

Screenshot (2).png




If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √