Happy Business Starts Here

Zuora Support

Real-Time Sync is switching to Turbo Sync

In my tenant Turbo Sync has been running for a while instead of Real-Time Sync.  Does anyone know what could cause the issue and how can I switch it back to Real-Time Sync?



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

1 REPLY 1
Zuora Support

Re: Real-Time Sync is switching to Turbo Sync

If your tenant is set up with Real-Time Sync, Turbo Sync could still be running due to the following reasons.

 

  1. High volume of data - Real-Time Sync is designed to sync a small set of new/updated records from Zuora to Salesforce as soon as possible for user convenience.  When there is a high number of records (~10,000) to be synced, in order to maximize the sync performance Turbo Sync is used instead.  After all records have been synced to Salesforce and several following Turbo Syncs (2 to 3 sessions) complete, the system will switch back to Real-Time Sync.

  2. Objects and fields migration - It is required that the sync user's profile has Customize Application permission when you run 360 Sync for the very first time and when you upgrade to a newer version of the Zuora 360 package.  This is to run newly introduced objects / fields / settings to Salesforce.  Without this permission, the syncs would keep retrying to sync all records which result in Turbo Sync (due to reason (1)).

  3. Issue with Migrated settings - Related to (2), settings cannot be set as 'Migrated' so the syncs keeps syncing all settings.  To resolve the issue, you can
    • Go to Setup > Develop > Custom Settings > "Manage" MigrationSettings
    • Look for duplicated settings that are not set as 'Migrated.' Delete one of the duplicates.
    • Run a Manual Sync in Zuora.  The remain setting should be set as 'Migrated.'  After that Real-Time Sync should start.


If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √