Happy Business Starts Here

Hosted Page not rendering for Z-Quotes

Highlighted
Zuora Staff

Hosted Page not rendering for Z-Quotes

Question:

 

An out of the box Hosted Payment Page that is setup in Zuora and in Salesforce is having issues rendering, how should I handle this problem?



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Zuora Staff

Re: Hosted Page not rendering for Z-Quotes

Solution:

 

Follow the steps below to help resolve this issue:

1. In your Salesforce instance, make sure to check the "API URL" defined in "Zuora Config" > "Zuora Connection Settings" under "Basic".

For connection to Zuora sandbox tenant, please make sure the URL is:
https://apisandbox-zforsf.zuora.com/apps/services/a/<version>

For connection to Zuora production tenant:
https://zforsf.zuora.com/apps/services/a/<version>

Where <version> is the WSDL version you're using.

2. Make sure HPM 2.0 is enabled in Salesforce tenant:

   -  Open Developer Console

   - Navigate to Debug > Open Execute Anonymous Window.

   - In the Enter Apex Code window, type:

      zqu.RefreshCustomSettingSchedulable.refreshHpmPermissions();

3. Check whether the HPM is configured correctly in Zuora and in Salesforce. Consult with documentation here: https://knowledgecenter.zuora.com/CA_Commerce/C_Zuora_Quotes/G_Zuora_Quotes_Configuration_Settings/M...

 

Supporting Documentation:

https://knowledgecenter.zuora.com/CA_Commerce/C_Zuora_Quotes/G_Zuora_Quotes_Configuration_Settings/A...



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

View solution in original post

1 REPLY 1
Highlighted
Zuora Staff

Re: Hosted Page not rendering for Z-Quotes

Solution:

 

Follow the steps below to help resolve this issue:

1. In your Salesforce instance, make sure to check the "API URL" defined in "Zuora Config" > "Zuora Connection Settings" under "Basic".

For connection to Zuora sandbox tenant, please make sure the URL is:
https://apisandbox-zforsf.zuora.com/apps/services/a/<version>

For connection to Zuora production tenant:
https://zforsf.zuora.com/apps/services/a/<version>

Where <version> is the WSDL version you're using.

2. Make sure HPM 2.0 is enabled in Salesforce tenant:

   -  Open Developer Console

   - Navigate to Debug > Open Execute Anonymous Window.

   - In the Enter Apex Code window, type:

      zqu.RefreshCustomSettingSchedulable.refreshHpmPermissions();

3. Check whether the HPM is configured correctly in Zuora and in Salesforce. Consult with documentation here: https://knowledgecenter.zuora.com/CA_Commerce/C_Zuora_Quotes/G_Zuora_Quotes_Configuration_Settings/M...

 

Supporting Documentation:

https://knowledgecenter.zuora.com/CA_Commerce/C_Zuora_Quotes/G_Zuora_Quotes_Configuration_Settings/A...



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

View solution in original post