Happy Business Starts Here

Fields are not loading when trying to create Rules on a specific object

Highlighted
Zuora Support

Fields are not loading when trying to create Rules on a specific object

Problem

In this specific scenario, customer is trying to create Rule and could see that fields are not loading as below on Account object

Screen Shot 2020-06-25 at 1.39.48 PM.png

 

Solution 

On reviewing the debug logs, below is stack trace from where error is thrown

 

21:16:02.1 (514743757)|EXCEPTION_THROWN|[34]|zqu.GenericException: Value operation returned an invalid data type: [TIME]
21:16:02.1 (514998686)|FATAL_ERROR|zqu.GenericException: Value operation returned an invalid data type: [TIME]Class.zqu.SchemaCache.getSupportedDataTypeBySchemaDescribe: line 214, column 1
Class.zqu.SchemaUtil.FieldDescription.<init>: line 49, column 1

It has been observed that there is custom field of data type "Time" on Account object

 

"TIME" is a new restricted data type added by salesforce which is  not supported in Flow Builder, Process Builder, and Schema Builder.

https://help.salesforce.com/articleView?id=custom_field_time_overview.htm&type=5

Hence, Rule engine is erroring out as it does not support this data type when loading fields

 

Issue is resolved when the field with data type "Time" is removed from the object or the data type has been changed






If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √