Happy Business Starts Here

Highlighted
Zuora Support

Custom field not syncing from Zuora to SF

How to check why custom fields are not syncing from Zuora to SF?






If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

1 REPLY 1
Zuora Support

Re: Custom field not syncing from Zuora to SF

Even after creating the custom fields both in SF and Zuora, the values are not syncing, then below could be the reason and solution for the same:

 

1. Check the permission on the custom field in SF.

 

i. Find the sync user from Zuora settings:

 

Settings -> Commerce -> Synchronize Salesforce.com Data

 

original2.png

ii. Goto salesforce ORG and check the profile for this user:

 

Setup -> Manage Users -> Users

 

iii. Now go to the Object associated with the custom field

 

Create -> Objects -> Click on the object name

 

iv. Select the custom field and now click on "Set Field-Level Security" and check if the profile has access to this field.

Check the access option and try the sync, the custom object must sync now.

 

2. Mismatched API Name or Data Type
 
Please check the API name and Data type for the custom field in both Zuora and SF, they need to match.
 
3. Values are assigned to the custom field in Zuora prior to custom field being created in Salesforce
 
Please make sure custom fields are created and SF, and then values assigned for same in Zuora.
 
Supporting KC article as below:
 






If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √