Happy Business Starts Here

NO_PERMISSION: Permission is required to modify an account.

Highlighted
Zuora Support

NO_PERMISSION: Permission is required to modify an account.

Question:

Hello – I need help in mass updating the Contact's WorkEmail field via Developer Tools (I have 4K email addresses that I need to update). I have Admin rights but getting the below error:

 

[Message] == Error Summary Start ==

[Message] [1] NO_PERMISSION: Permission is required to modify an account. Please contact your company administrator for permission.

[Message] == Error Summary End ==

 

Can you please help?

 

Root Cause:

The user you used to update the contact via the Developer tool is "abcd@xyz.com". The user's Billing Role is "Billing - Catalog Only" and that doesn't have access to Account & Contact records.

 

 

 

Solution:

 

We need to provide atleast "Modify Account" permission under "Billing" role in order to update the Contact's Details.

 

Billing Permissions 

 

Once this permission is provided, customer can able to update the Account's Contact details.






If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √