Happy Business Starts Here

Usage Import Fail reasons file returns "Not Found" error

Aslam
Community Manager

Usage Import Fail reasons file returns "Not Found" error

Question:

 

When we try to open the Usage import failed reasons file, it returns

 

'Not found. The page you were looking for could not be found. If you believe you reached this page in error, please email support@zuora.com'

 

We have tried using an incognito browser and clearing the cache memory and it doesn't help.

 

Answer:

The error reported here was in Multi-Entity enabled tenant. The problem seems to happen when the user was already logged in to another Entity and trying to access the usage failed file that belongs to some other entity. The right way to do this would be to make sure that the user is enabled in the correct Entity before opening the Usage failed reasons file. 

 

The customer was using a valid credential to log onto the billing service. So the authentication is good actually.
In https://knowledgecenter.zuora.com/Billing/Tenant_Management/Multi-entity/A_Overview_of_Multi-entity, we have documented that the client should provide the correct entity id to access.
In other words, the client has to tell Zuora billing that which entity the request want to access through the headers. The billing service itself doesn’t know if the customer is accessing the correct entity or not."

 

 





If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √