Happy Business Starts Here

Table Sort is not working as expected in Invoice template

Zuora Support

Table Sort is not working as expected in Invoice template


Hi Support Team,

I have tried to sort the invoice for the service period, but I must be doing something wrong.

I would like to have it displayed as:

Jan 5.000 €

Feb 5.000 €

March 5.000 €

April 5.000 €


I have copied the below code from the article, but it is not working. So something must be wrong and I don’t see it.


{ MERGEFIELD "TableSort:InvoiceItem.ChargeNumber ASC, InvoiceItem.AmountWithoutTax DESC" \* MERGEFORMAT }

Can you please help?





When checked at the customer's Invoice template and it seems Table Sort functionality is not added as merge field format even though we can see merge field wordings in it(highlighted)

To identify a field is merge field or not, place the mouse over the field and click on the right mouse button then it should show below-highlighted options:

But in the customer's template, when mouse pointer is placed over the Tablesort function, we couldn't see that option. Please check the below screenshot.

The customer just copied the Table Sort format from the KC article and pasted it in their template. That is why Table Sort functionality didn't work as expected.


Once the merge field is inserted properly, Table Sort functionality is working.


KC articles for reference - 



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √