Happy Business Starts Here

Invoice Template not displaying currency symbol, instead it shows the text

Highlighted
Zuora Support

Invoice Template not displaying currency symbol, instead it shows the text

Problem:

Please find attached Invoice Template format and sample PDF, our main requirement is display $ instead of USD shown in Invoice. We updated our template to display $ symbol, but still USD is being printed in the PDF. Please help

 

Capture4.JPG

 

Capture5.JPG

 

Solution:

 

In general, Invoice PDF renders based on the Locale settings. In this case, customer has Default Profile and the tenant's Locale setting is "English (United Kingdom)"

 

Capture6.JPG

 

Invoice's Account Currency is set in USD. Since default setting(UK) and the Invoice Currency is in two different currencies, while generating the PDF, it still renders with USD text format and not with $ symbol. Invoice Rendering (Aspose) behavior is not supported when 2 different currencies are used.

 

 This can be avoided by the following options:

 

  • Set the Tenant's default to match the Currency enabled(if the tenant is using single currency for transactions)
  • Update the Locale in DEFAULT Settings
  • If the Default settings cannot be changed, create a new custom profile and update the proper Locale and assign the profile the it's respective Customer Accounts.

Below is the sample testing from our Inhouse tenant:

 

Capture7.JPG

 

 

 






If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √