Happy Business Starts Here

We got 200 responses from the API but looks like the Account was not Created in the UI

Highlighted
Zuora Support

We got 200 responses from the API but looks like the Account was not Created in the UI

Question: We are in the process of the investigation a case when a user tried to signup to a plan, we got 200 responses from the API but looks like the account was not created.

 

These are the Account IDs that we got back, but looks like none of them are created:

"2c92a0076e68e3ee016e7fbbe5a70406" 
"2c92a0ff6e68f558016e7eb30d225595"

Capture.PNG

 

Can you please check what's the reason why the https://rest.zuora.com/v1/action/subscribe endpoint returned 200 but doesn't create accounts for these cases?

 

We have attached our request/response here. Please, Advice?




If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Zuora Support

Re: We got 200 responses from the API but looks like the Account was not Created in the UI

Answer:

 

We checked that the attached Subscribe API CalI and realized that these were only previewed calls ("EnablePreviewMode": true) hence the account IDs are invalids. 

 

POST https://rest.apisandbox.zuora.com/v1/action/subscribe

 

"PreviewOptions": {
"EnablePreviewMode": false
},

 

Please make sure the EnablePreviewMode is false and execute attached Subscribe API Call to create a account.




If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

View solution in original post

1 REPLY 1
Highlighted
Zuora Support

Re: We got 200 responses from the API but looks like the Account was not Created in the UI

Answer:

 

We checked that the attached Subscribe API CalI and realized that these were only previewed calls ("EnablePreviewMode": true) hence the account IDs are invalids. 

 

POST https://rest.apisandbox.zuora.com/v1/action/subscribe

 

"PreviewOptions": {
"EnablePreviewMode": false
},

 

Please make sure the EnablePreviewMode is false and execute attached Subscribe API Call to create a account.




If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

View solution in original post