Happy Business Starts Here

[REST] Why is the custom field I've added not returning by successful REST API call?

Highlighted
Zuora Staff

[REST] Why is the custom field I've added not returning by successful REST API call?

Problem:

 

With a custom field in "Product Rate Plan Charge" added, and according to this Knowledge Center article, when sending a REST API call to get Subscription by Key, custom fields should also be returned. Why am I not seeing the new custom field I've added?



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Zuora Staff

Re: [REST] Why is the custom field I've added not returning by successful REST API call?

Solution:

 

Since the REST API call is retrieving Subscription by key, note that the object "Product Rate Plan Charge" has not relation to the "Subscription" object. Therefore, the newly created field isn't returned. One way to confirm is to, go to "Data Exports" under "Z-Reporting" from the left panel, select "Subscription" as "Data Source", the "Rate Plan Charge" object does not show up in the "Fields" section.

 

Supporting Documentation:


Product Rate Plan Charge Data Source: https://knowledgecenter.zuora.com/CD_Reporting/Data_Exports/Z_Data_Source_Reference/Product_Rate_Pla...

Subscription Data Source: https://knowledgecenter.zuora.com/CD_Reporting/Data_Exports/Z_Data_Source_Reference/Subscription_Dat...



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

View solution in original post

1 REPLY 1
Highlighted
Zuora Staff

Re: [REST] Why is the custom field I've added not returning by successful REST API call?

Solution:

 

Since the REST API call is retrieving Subscription by key, note that the object "Product Rate Plan Charge" has not relation to the "Subscription" object. Therefore, the newly created field isn't returned. One way to confirm is to, go to "Data Exports" under "Z-Reporting" from the left panel, select "Subscription" as "Data Source", the "Rate Plan Charge" object does not show up in the "Fields" section.

 

Supporting Documentation:


Product Rate Plan Charge Data Source: https://knowledgecenter.zuora.com/CD_Reporting/Data_Exports/Z_Data_Source_Reference/Product_Rate_Pla...

Subscription Data Source: https://knowledgecenter.zuora.com/CD_Reporting/Data_Exports/Z_Data_Source_Reference/Subscription_Dat...



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

View solution in original post