Happy Business Starts Here

Highlighted
Valued Scholar

PHP REST wrapper has improper composer configuration

I noticed that the PHP REST API wrapper has misconfigured Composer properties, and the README.md section on Composer installation relfects those as well. Specifically, it seems that some placholders in a Swagger config did not get filled in with proper values, resulting in the package's name being GIT_USER_ID/GIT_REPO_ID. This results in a similarly named folder structure in vendor/ upon installation. 

 

I forked the project and committed a patch, then submitted a pull request: https://github.com/zuora/codelibrary-php/pull/1

 

I recognize that accepting the pull may not be the best fix from your end given the Swagger generation involed, but if some action could be taken I'd appreciate it.

 

An added bonus would be to register the package at https://packagist.org so that the repository addition to local composer.json files wouldn't be necessary.

 

Thanks very much for your consideration!

Jim

2 REPLIES 2
Zuora Product Team

Re: PHP REST wrapper has improper composer configuration

@JAAulde, thank you for the pull request. We've now merged it in and are looking to see if we can make this a more permanent fix within codegen. We'll also consider your suggestion of using packagist.org in the future. Again, thank you for submitting this, and please keep the suggestions coming, we really appreciate them.

 

Valued Scholar

Re: PHP REST wrapper has improper composer configuration

Great, thank you very much!