Happy Business Starts Here

Highlighted
Senior Tutor

Error when connecting to Soap Client in .NET 4.0

I had initially tested my app with Zuora Soap client using Visual Studio 2015 and .NET 4.6. It worked perfect.

 

However, I had to implement this code for another client using .Net 4.0. My code (a simple login itself: _zuoraSoapClient.login) fails to connect to the zuora server with the following error. I tried changing my working .NET 4.6 project to run on .NET 4.0 and am able to reproduce this error.

 

An error occurred while making the HTTP request to https://apisandbox.zuora.com/apps/services/a/75.0.
This could be due to the fact that the server certificate is not configured properly with HTTP.SYS in the HTTPS case.
This could also be caused by a mismatch of the security binding between the client and the server.

 

I googled and came across the below link:

http://stackoverflow.com/questions/2013880/wcf-error-this-could-be-due-to-the-fact-that-the-server-c...

One of the comments is below:

If your WCF service is using .net framework 4.0 and someone has disabled TLS 1.0 on the server then you will see this exception. Due to .net 4.0 not supporting the higher versions of TLS.

Supported protocols: https://msdn.microsoft.com/en-us/library/system.security.authentication.sslprotocols(v=vs.100).aspx

1 REPLY 1
Support SME

Re: Error when connecting to Soap Client in .NET 4.0

Hi @jmichael,

 

the quoted comment is right: we are indeed deprecating TLS1.0 as it's an outdated encryption protocol. Please review our Community topic on adjusting to these changes: http://community.zuora.com/t5/Zuora-Announcements/Action-Required-Zuora-is-Disabling-TLS-1-0/ba-p/21...



If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √