Happy Business Starts Here

Additional columns in export in AQUA API query

Highlighted
Support SME

Additional columns in export in AQUA API query

I'm building extraction jobs that query the AQUA API and the results seem to be returning extra columns/fields on several objects. The columns seem to be the same but happen across most of the objects related to Invoice.

 

For example, when I run this query:

 

 

"Select Id, Amount, CreatedById, CreatedDate, Invoice.Id, Payment.Id, RefundAmount, UpdatedById, UpdatedDate FROM InvoicePayment"

 

I am getting the following additional columns in my export CSV:

 

  • InvoicePayment.AmountHomeCurrency   
  • InvoicePayment.AmountCurrencyRounding   
  • InvoicePayment.ExchangeRate   
  • InvoicePayment.ExchangeRateDate   
  • InvoicePayment.ProviderExchangeRateDate   
  • InvoicePayment.HomeCurrency   
  • InvoicePayment.TransactionCurrency

 

 






If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Support SME

Re: Additional columns in export in AQUA API query

There is a setting in your Currency Conversion settings that automatically includes these additional Currency Conversion fields in data source exports which AQUA API Extraction jobs.

 

Zuora 2017-11-10 at 9.01.58 AM.png

 

You can choose to disable this feature by navigating to Settings > Finance Settings > Manage Currency Conversion, then uncheck the box for "Automatically include additional Currency Conversion information in data source exports".






If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

View solution in original post

1 REPLY 1
Highlighted
Support SME

Re: Additional columns in export in AQUA API query

There is a setting in your Currency Conversion settings that automatically includes these additional Currency Conversion fields in data source exports which AQUA API Extraction jobs.

 

Zuora 2017-11-10 at 9.01.58 AM.png

 

You can choose to disable this feature by navigating to Settings > Finance Settings > Manage Currency Conversion, then uncheck the box for "Automatically include additional Currency Conversion information in data source exports".






If you found my answer helpful, please give me a kudo ↑
Help others find answers faster by accepting my post as a solution √

View solution in original post