Happy Business Starts Here

API general errors due to Zuora REST API version and Zuora WSDL version

Highlighted
Zuora Support

API general errors due to Zuora REST API version and Zuora WSDL version

Problem:

API general errors due to Zuora REST API version and Zuora WSDL version

 

Scenario 1:

 

User receives the error message even though they are using the New API call that supports the Invoice settlement

https://www.zuora.com/developer/api-reference/#operation/POST_Subscription

"message": "You have already enabled Invoice Settlement Permission, payment and refund in Zuora UI and SOAP API are still in process, please use the new REST API."

 

Solution:

The invoice settlement fields are in Zuora REST API version control. zuora-version  should be set as 211.0  or later in the header.

 

 

Scenario 2:

 

User faces below error message when they are using CreateExport APi (/v1/object/export) 

Error Message : noSuchDataSource :[object]   

 

Solution:

Zuora WSDL version plays key role in the Data source object error, Latest WSDL version should be updated to get the recently added objects 

X-Zuora-WSDL-Version: 88.0 

 

Tags (1)